Service degraded in Singapore region

Incident Report for AdvaPACS

Resolved

This incident has been resolved.
Posted Mar 28, 2026 - 03:21 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 28, 2026 - 02:22 UTC

Monitoring

The infrastructure has now scaled, and we have seen load return to normal levels. We will continue to monitor.
Posted Mar 28, 2026 - 02:22 UTC

Identified

An issue has been identified due to high customer load. We are scaling resources to provide extra capacity.
Posted Mar 28, 2026 - 01:48 UTC

Investigating

We are currently investigating reports of AdvaPACS responding slowly in the Singapore region.
Posted Mar 28, 2026 - 01:38 UTC
This incident affected: Singapore Region (AdvaPACS Platform, MedDream Viewer, eUnity Viewer, DICOMweb API, FHIR API, FHIRcast Hub).