RADPAIR Service Disruption in All Regions

Incident Report for AdvaPACS

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 04:28 UTC

Identified

The issue has now been identified with RADPAIR's API and has been escalated to their team for investigation.
Posted Mar 13, 2026 - 02:44 UTC

Investigating

We are currently investigating this issue.
Posted Mar 13, 2026 - 02:41 UTC
This incident affected: RADPAIR.