eUnity Service Degradation in MYS

Incident Report for AdvaPACS

Resolved

We have increased the resources available to the eUnity servers and after a period of monitoring have not observed a recurrence of the issue.
Posted May 28, 2026 - 10:13 UTC

Update

We are continuing to investigate this issue.
Posted May 28, 2026 - 04:45 UTC

Investigating

We are currently investigating this issue.
Posted May 28, 2026 - 04:39 UTC
This incident affected: Malaysia Region (eUnity Viewer).